내 플러그인을 지원하는 최소 워드프레스 버전은?

워드프레스 헤더 중 Requires at least라는 항목이 존재한다. 해당 플러그인, 테마가 정상 동작할 수 있는 최소 워드프레스 버전을 의미한다.

워드프레스는 계속 변화한다. 새 함수가 소개되기도 하고, 기존의 함수가 폐기 처분되기도 한다. 새 함수를 사용하면 아무래도 좀 더 편하기 코드 작성이 가능하다. 그러나 그만큼 호환성에 문제가 생기기도 한다. 이 때 이 안정성을 보장하기 위해 이 헤더가 존재한다.

워드프레스 코어 버전이 여기에 적힌 버전보다 낮다면 플러그인은 제대로 활성화되지 않는다. 활성화된 플러그인이 에러를 내서 사이트가 다운되는 것 보다는 애초에 활성화되지 않는 것이 더 낫기 때문이다.

그러므로 플러그인 개발자는 좀 더 친절하게 이 항목을 적어 두는 것이 좋다.

그런데 문제는 내가 작성한 프로그램의 수많은 함수를 보면서 어떤 함수가 워드프레스 코어 어떤 버전에서 추가되었는지 (혹은 폐기되었는지) 찾기 어렵다.

https://wpseek.com/pluginfilecheck/

이럴 때 이 사이트를 쓰면 편리하다. 코드를 업로드하면 프로그램의 소스를 분석해서 워드프레스의 코어에 함수가 포함된 버전을 알아서 정리해 준다. 그리고 어떤 버전을 최소로 해야 할지를 결정해 준다.

내가 작성한 코드에 대한 결과 예시. 최소 버전이 5.3.0이라고 알려 준다.
어떤 함수를 썼고, 그게 어떤 버전에서 추가되었는지 분석한다.

결과 화면의 일부분에는 그림처럼 사용된 모든 함수의 추가 지점을 정리해 준다. 여기서 내가 wp_date()라는 함수를 사용했고, 이 함수는 5.3.0에서 추가되었다는 사실을 명확히 보여준다.

이 사이트에서 내 코드를 올리는 게 조금 찜찜하기는 하지만, 설마 코드를 수집해서 뭘 할 거 같지는 않다. 북마크에 저장해두고 유용히 쓰자.

댓글 1개

댓글 남기기